Having trouble using the forums?

shaines

Administrator
Staff member
Aug 22, 2019
112
179
4,760
Visit site
Hey there!

We've followed up on several reports of issues and can confirm that some forum accounts have lost access unexpectedly over the last few days. Unfortunately, Microsoft has temporarily blocked our emails, so anyone using Hotmail, Live, Outlook, or Microsoft email domains will not receive any emails. This also means your forum account may revert to a state where it's "Awaiting Verification." This kind of thing does happen with various different domains periodically, but it gets cleared up quickly, when it's not a holiday season (very unfortunate timing).

For anyone who'd like to resolve this issue immediately, feel free to update your email address on the forums to any email address other than Microsoft, such as Gmail or Yahoo. I'll update this thread when the issue is resolved, so you can swap back to the preferred email address whenever you'd like. Anyone who'd like our team to update the email address for you, just email your request to community@futurenet.com and we'll get that sorted out ASAP.

Thanks for your patience!
 

shaines

Administrator
Staff member
Aug 22, 2019
112
179
4,760
Visit site
Hey again!

The issue appears to be clearing up for folks now. We've not had official word of it being fixed, but we've tried multiple tests and have been receiving emails again via Microsoft domains. There's a chance of some slight lingering issues, but things mostly appear back to normal.

Thanks for your patience!
 
I have a hotmail address. After re-sending each day since this happened, I finally got an email yesterday. And was able to log in with all privileges. My email address is 25 years old. I have yahoo and gmail addresses with the same age, but my email program can not retrieve them. And I hate going to a website to check if I have email. But I keep those addresses for their age.
 

Latest posts